看看WORDPRESS最近的PHP最低要求

就编程语言而言,PHP经常会获得重大更新。这意味着随着时间的推移,WordPress需要更新所需的最低PHP版本以跟上这些更新并为用户提供更好的体验。

在阅读本文时,WordPress正在跳转到PHP 5.6版。它不是最新的PHP版本,但它仍然是一个重大变化,它将影响WordPress用户的工作方式。但是,没有必要担心:这次更新是件好事。

在本文中,我们将打破最低PHP要求跳跃的原因。然后我们将解释如何使用这个新的PHP版本将对您产生影响,以及如何更新到更新的版本。我们来聊聊PHP吧!

WordPress的最低PHP需求跳跃解释

一段时间以来,WordPress的最低PHP版本要求已在版本5.2-5.5中设置。早在2018年12月,就有人建议在2019年4月将最低PHP要求更新到5.6版,以鼓励WordPress用户实现更安全,性能更好的版本。

最低要求的变化主要针对可能不知道他们正在运行弃用版本的用户。有关新要求的警报将告知经验不足的用户需要进行PHP更新,这有望使他们切换到具有更好安全性,性能和支持的版本。

自从宣布这一变化以来,很多人都质疑跳过PHP版本7是不是更好。毕竟,5.6并不是最近发布的版本。

然而,要理解为什么变化需要渐进,我们需要看一些数字。统计数据显示,大约20%的用户仍在运行从5.2到5.5的PHP版本,这不是一个微不足道的数字。

有一段时间以来,WordPress一直在推动用户更新我们的PHP版本,并且提高最低要求可能会加快这一过程。缓慢增加需求应该使旧版本PHP的用户更容易逐步进行更改并确保其站点保持不变。

如果事情进展顺利,已经有计划在2019年12月之前将WordPress的最低PHP要求一直提升到版本7.但是,如果你愿意的话,没有什么可以阻止你升级到最新版本的PHP。

最低PHP要求的跳跃将如何影响你

PHP版本更新提供了许多好处。那些当前正在运行旧版本并升级以满足新的最低要求的人应该看到安全性和性能方面的改进。他们还可以访问其他功能和支持。

对于开发人员来说,对WordPress最低PHP版本的更新有望减少令人头疼的问题。例如,插件开发人员不需要处理那些坚持弃用版本或存在兼容性问题的用户的支持请求。

如果您的客户或用户坚持坚持使用较旧的PHP版本,那么您现在有充分的理由坚持更新。这将使您可以访问更新版本的PHP中提供的各种其他开发功能,使您的工作更轻松(并希望更有趣!)。

有几个站点运行过时的PHP版本的开发人员 – 无论是出于客户的意愿还是因为他们在更新方面稍稍落后 – 在他们获得这些好处之前都会有相当多的工作。如果您遇到这种情况,请尝试查看您的网站托管服务商是否可以帮助您升级而不必担心。

如何升级您的PHP版本

我们过去曾谈到过如何升级你的PHP版本。这是一个快速回顾:

  1. 备份您的网站并升级其所有组件。
  2. 使用插件检查您的网站是否存在与较新版本的PHP的兼容性问题。
  3. 更新到新版本。
  4. 检查您的网站是否有与更新相关的任何不需要的更改。

在大多数情况下,只要您的提供商支持您所需的版本,您就可以直接从主机仪表板切换到较新版本的PHP。目前,PHP 7支持非常普遍,因此我们建议您直接跳到它。

无论您决定更新哪个版本,请务必不要跳过我们刚才概述的第一步和第二步。它们不是  绝对 必要的,但它们不应该花费很长时间,它们会帮助您确保过渡顺利进行。

结论

WordPress最低PHP版本的更新对于您作为开发人员来说是个好消息。马上,这意味着您不需要支持仍在运行旧版PHP版本的用户。该更新现已上线,因此我们应尽快开始收益。

然而,我们真正感到兴奋的是,在今年年底之前提议跳转到PHP版本7。您可能知道,版本7带来了性能的大幅提升,我们一直试图说服人们升级它一段时间。

说点什么

500